Compact Export

Compact Export


Ever exported a config from RouterOS and saw tons of lines of garbage you didn’t need or sometimes even recognize? If so, you will love this!

Starting from v5.12 compact export was added. It allows to export only part of configuration that is not default RouterOS config.

[admin@SXT-ST] /routing ospf> export compact

# jan/02/1970 20:16:32 by RouterOS 5.12

# software id = JRB7-9UGC

#

/routing ospf instance

set [ find default=yes ] redistribute-connected=as-type-1

/routing ospf interface

add disabled=yes interface=wlan1 network-type=point-to-point

/routing ospf network

add area=backbone network=10.255.255.36/32

add area=backbone disabled=yes network=10.5.101.0/24

add area=backbone network=10.10.10.0/24

[admin@SXT-ST] /routing ospf>

Compact export introduces another feature that indicates which part of config is default on RouterOS and cannot be deleted. As in example below ‘*’ indicates that this OSPF instance is part of default configuration.

[admin@SXT-ST] /routing ospf instance> print

Flags: X – disabled, * – default

0 * name=”default” router-id=0.0.0.0 distribute-default=never

redistribute-connected=as-type-1 redistribute-static=no

redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=no

metric-default=1 metric-connected=20 metric-static=20 metric-rip=20

metric-bgp=auto metric-other-ospf=auto in-filter=ospf-in

out-filter=ospf-out

Steve Discher

Steve Discher was born in Apple Valley, California and today makes his home in College Station, Texas with his wife and three children. He is a 1987 graduate of Texas A-M University and owns ISP Supplies, a wireless distribution company, and conducts MikroTik training classes. His hobbies include flying his Piper Cub and RV camping with his family.

Recent Posts

  • Using MikroTik LHG as a UE With a Baicells eNodeB

    This has been a dream for a long time, and a DIY project for those industrious individuals willing to cobble it together, but now it is a reality in a production device. First of all why would you want to …

  • New ISP Supplies App

    Now available on the Playstore and the iPhone Appstore, the ISP Supplies App! With great features like a powerful search engine and a reorder list, it makes it fast and easy to place orders on the go. Favorite products for quick …

  • Update: Block Countries Based on IP Addresses and Networks

    If you never used my web site https://mikrotikconfig.com to build firewalls and QOS, you have been working too hard! I recently (today) updated the database of IP addresses by Country to generate MikroTik IP Address Lists by country. Check it …

See More News